GTA 4 – the install

I took a break from the end-of-semester blues and bought a copy of GTA 4. No store had it in Memphis on Dec. 2; I only found it at Target on Dec. 3.

I was in a pretty good mood until I noticed the package’s statement that SP3 was required. Putting in the first DVD confirmed this – it would not even start to install without SP3. Now I’ve successfully avoided upgrading my operating system on the gaming rig for years. I’m not fond of XP, but I’ve run it on no less than four builds at home, and I know its many peccadillos. And I’ve seen the chaos that SP3 can wreck. However, I was fond of the PC port of San Andreas, so I took a deep breath and installed SP3 on my machine, which already has an intermittent boot problem that I have been working around by switching between SATA ports.

Installing SP3 took three hours, about two hours more than necessary after many mysterious errors. On the final attempt, after a registry hack that bypassed most the problems, it bluescreened (my intermittent problem, or SP3?), but then rebooted successfully. You tell me how that works.

Most everything still worked after that, though my virtual drive software somehow become decoupled from its SCSI driver. But I figured that was no great loss, and I should plow ahead.

With SP3 in place, the GTA 4 DVD was sated enough to consider installation. I knew what was coming, but I still cringed as it gave me no choice but to install a ‘Social Club’ application, a fresh SecuROM suite, and some Games For Windows nonsense. This took nearly an hour, and as there are two DVDs – the game is about 15 gigs all told – I had to wait on the beast and switch DVDs like I was back in 1990 with a box full of 3 1/2 disks (Quest for Glory II, I’m thinking of YOU). Of course, the DVD switching was fouled up, and I had to start the installation over again.

Four hours after starting, I finally get to start the game, only to find that I must enter a security code off the manual, and let SecuROM connect to the internet, though I suspect more than this actually happened. My software firewall went ballistic – I had to ok no less than a dozen different access requests by a multitude of processes. And then I was chastised for not logging into the Social Club app, though it seems possible to play the game without connecting to that.

The game itself, if you’re willing to go though the minor hell of installation, is fine. It’s actually quite good, especially since I upgraded my machine to a quad-core a few months ago in preparation. The driving physics are very much improved, and the storyline is reasonable, as well as more serious in tone than the previous installments. I can tell the engine is not quite optimized, though, and there is an extremely annoying bug with the bowling mini-game that makes it impossible to play. It’s nothing a patch couldn’t fix, though.

I’m disappointed that Rockstar has proved incapable of delivering a clean, no-frills PC port. In particular, I can’t imagine why SP3 was required for the game itself; the demand for it must be linked to the social/multiplayer content, which I will never use, as I am a single-player fanatic. Rockstar should have made that content an optional install, like every other sane game publisher does. Their stubborness is just going to lead to the inevitable – a pirated release that will not only be easier to install, but will probably run faster, and which people will flock to rather than buying the game.

You can leave a comment!